# CVE-2022-2818: Improper Removal of Sensitive Information Before Storage or Transfer in cockpit-hq/cockpit

> Attackers can access sensitive information due to improper removal before storage or transfer in Cockpit CMS.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8wj3-cpmr-8whp

## What is CVE-2022-2818?

CVE-2022-2818 is a critical vulnerability in cockpit-hq/cockpit, published on 15 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository cockpit-hq/cockpit prior to 2.2.2.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2022-2818?

2 open source packages ship an affected version, including cockpit-hq/cockpit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.2.2 |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.2.2 |

Products: Agentejo Cockpit.

## How do I fix CVE-2022-2818?

Upgrade cockpit-hq/cockpit to 2.2.2 or later.

## Is CVE-2022-2818 being exploited?

There is no known exploitation of CVE-2022-2818 in the wild and no public exploit code.

## Other vulnerabilities in cockpit-hq/cockpit

- [CVE-2023-4195](https://insights.sbomify.com/CVE-2023-4195/): PHP Remote File Inclusion in cockpit-hq/cockpit (critical 9.9)
- [CVE-2024-4825](https://insights.sbomify.com/CVE-2024-4825/): Unrestricted Upload of File with Dangerous Type vulnerability on Cockpit CMS from Agentejo (critical 9.8)
- [CVE-2020-35131](https://insights.sbomify.com/CVE-2020-35131/): Code injection in n/a (critical 9.8)
- [CVE-2020-35846](https://insights.sbomify.com/CVE-2020-35846/): SQL injection in n/a (critical 9.8)
- [CVE-2020-35847](https://insights.sbomify.com/CVE-2020-35847/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2818 and fix it if it is affected.

What it is: CVE-2022-2818 is a critical vulnerability in cockpit-hq/cockpit, published on 15 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2818 in the wild and no public exploit code.

Affected packages and fixed versions:
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.2.2
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2818/ (Markdown: https://insights.sbomify.com/CVE-2022-2818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2818
- OSV: https://osv.dev/vulnerability/CVE-2022-2818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2818/
Summaries are generated and may contain mistakes; the official description above is the record.
