CVE-2022-28201 Denial of service in n/a
Users with editinterface permission can cause infinite recursion and denial of service by mishandling bare local interwikis in the mainpage message.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-28201?
CVE-2022-28201 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. Users with the editinterface permission can trigger infinite recursion, because a bare local interwiki is mishandled for the mainpage message.
Weakness: CWE-674
Which versions are affected by CVE-2022-28201?
1 open source package ship an affected version, including mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.6, 1.36.4, 1.37.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2022-28201?
Upgrade mediawiki to a fixed version for your release line: 1.35.6, 1.36.4 or 1.37.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-28201 being exploited?
There is no known exploitation of CVE-2022-28201 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2022-28201, DEBIAN-CVE-2022-28201, GHSA-3fgq-p3w2-7q9w, UBUNTU-CVE-2022-28201.