{"answers":{"affected":"1 open source package ship an affected version, including mediawiki. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-28201 in the wild and no public exploit code.","fix":"Upgrade mediawiki to a fixed version for your release line: 1.35.6, 1.36.4 or 1.37.2.","what":"CVE-2022-28201 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28201 and fix it if it is affected.\n\nWhat it is: CVE-2022-28201 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28201 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.35.6, 1.36.4, 1.37.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28201/ (Markdown: https://insights.sbomify.com/CVE-2022-28201/index.md)","id":"CVE-2022-28201","markdown":"https://insights.sbomify.com/CVE-2022-28201/index.md","name":"CVE-2022-28201","record":{"aliases":["BIT-mediawiki-2022-28201","DEBIAN-CVE-2022-28201","GHSA-3fgq-p3w2-7q9w","UBUNTU-CVE-2022-28201"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MediaWiki","requires_auth":"high_privilege","summary":"Users with editinterface permission can cause infinite recursion and denial of service by mishandling bare local interwikis in the mainpage message.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":4.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"An issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. Users with the editinterface permission can trigger infinite recursion, because a bare local interwiki is mishandled for the mainpage message.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-28201","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","mediawiki:mediawiki"],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-28202"},"packages":[{"ecosystem":"Bitnami","fixed":["1.35.6","1.36.4","1.37.2"],"introduced":["0","1.36.0","1.37.0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2022-28201"}],"prev":{"headline":"Memory corruption in NVIDIA DGX A100","id":"CVE-2022-28200"},"products":["n/a"],"published":"2022-09-19","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Users with editinterface permission can cause infinite recursion and denial of service by mishandling bare local interwikis in the mainpage message.","url":"https://insights.sbomify.com/CVE-2022-28201/"}