CVE-2022-28202 Cross-site scripting in n/a
Attackers can inject malicious scripts via unescaped message properties in galleries or RevisionDelete, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-28202?
CVE-2022-28202 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An XSS issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. The widthheight, widthheightpage, and nbytes properties of messages are not escaped when used in galleries or Special:RevisionDelete.
Weakness: CWE-79
Which versions are affected by CVE-2022-28202?
1 open source package ship an affected version, including mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.6, 1.36.4, 1.37.2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2022-28202?
Upgrade mediawiki to a fixed version for your release line: 1.35.6, 1.36.4 or 1.37.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-28202 being exploited?
There is no known exploitation of CVE-2022-28202 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2022-28202, DEBIAN-CVE-2022-28202, GHSA-5c63-m98j-vx6v, UBUNTU-CVE-2022-28202.