CVE-2022-28203 Denial of service in n/a

High 7.5 Published Updated

Attackers can cause denial of service in MediaWiki by triggering long-running database queries via the Special:NewFiles page.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-28203?

CVE-2022-28203 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A denial-of-service issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. When many files exist, requesting Special:NewFiles with actor as a condition can result in a very long running query.

Weakness: CWE-763

Which versions are affected by CVE-2022-28203?

1 open source package ship an affected version, including mediawiki. It affects 2 products.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.35.6, 1.36.4, 1.37.2

Products include Debian Debian Linux, Mediawiki Mediawiki.

How do I fix CVE-2022-28203?

Upgrade mediawiki to a fixed version for your release line: 1.35.6, 1.36.4 or 1.37.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-28203 being exploited?

There is no known exploitation of CVE-2022-28203 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as BIT-mediawiki-2022-28203, DEBIAN-CVE-2022-28203, GHSA-647g-vgr2-5gqc, UBUNTU-CVE-2022-28203.

Is CVE-2022-28203 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free