# CVE-2022-28203: Denial of service in n/a

> Attackers can cause denial of service in MediaWiki by triggering long-running database queries via the Special:NewFiles page.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2022-28203, DEBIAN-CVE-2022-28203, GHSA-647g-vgr2-5gqc, UBUNTU-CVE-2022-28203

## What is CVE-2022-28203?

CVE-2022-28203 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial-of-service issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. When many files exist, requesting Special:NewFiles with actor as a condition can result in a very long running query.

Weakness: CWE-763 (Release of Invalid Pointer or Reference)

## Which versions are affected by CVE-2022-28203?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.6, 1.36.4, 1.37.2 |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2022-28203?

Upgrade mediawiki to a fixed version for your release line: 1.35.6, 1.36.4 or 1.37.2.

## Is CVE-2022-28203 being exploited?

There is no known exploitation of CVE-2022-28203 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28203 and fix it if it is affected.

What it is: CVE-2022-28203 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 19 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28203 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.6, 1.36.4, 1.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28203/ (Markdown: https://insights.sbomify.com/CVE-2022-28203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28203
- OSV: https://osv.dev/vulnerability/CVE-2022-28203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28203/
Summaries are generated and may contain mistakes; the official description above is the record.
