# CVE-2022-28206: Missing authorization in n/a

> Attackers can bypass edit rights checks in the FileImporter extension to perform unauthorized file imports or modifications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2022-28206, GHSA-jr52-cgg9-p2ph

## What is CVE-2022-28206?

CVE-2022-28206 is a critical missing authorization vulnerability in Mediawiki Mediawiki, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MediaWiki through 1.37.1. ImportPlanValidator.php in the FileImporter extension mishandles the check for edit rights.

## Which versions are affected by CVE-2022-28206?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.37.2 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2022-28206?

Upgrade mediawiki to 1.37.2 or later.

## Is CVE-2022-28206 being exploited?

There is no known exploitation of CVE-2022-28206 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28209](https://insights.sbomify.com/CVE-2022-28209/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28206 and fix it if it is affected.

What it is: CVE-2022-28206 is a critical missing authorization vulnerability in Mediawiki Mediawiki, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28206 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28206/ (Markdown: https://insights.sbomify.com/CVE-2022-28206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28206
- OSV: https://osv.dev/vulnerability/CVE-2022-28206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28206/
Summaries are generated and may contain mistakes; the official description above is the record.
