CVE-2022-28220 STARTTLS command injection in Apache JAMES

High 7.5 Published Updated

Attackers can exploit a parser differential in the STARTTLS command to inject commands, potentially leading to code execution on the mail server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-28220?

CVE-2022-28220 is a high-severity command injection vulnerability in Apache James, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache James prior to release 3.6.3 and 3.7.1 is vulnerable to a buffering attack relying on the use of the STARTTLS command. Fix of CVE-2021-38542, which solved similar problem fron Apache James 3.6.1, is subject to a parser differential and do not take into account concurrent requests.

Weakness: CWE-77

Which versions are affected by CVE-2022-28220?

4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.

PackageAffectedFixed in
org.apache.james:james-server MavenAll versions3.6.3
org.apache.james:james-server MavenAll versions3.6.3
org.apache.james:james-server MavenFrom 3.7.03.7.1
org.apache.james:james-server MavenFrom 3.7.03.7.1

Products include Apache James.

How do I fix CVE-2022-28220?

Upgrade org.apache.james:james-server to a fixed version for your release line: 3.6.3 or 3.7.1.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-28220 being exploited?

There is no known exploitation of CVE-2022-28220 in the wild and no public exploit code.

Sources

Also known as GHSA-w45j-f5g5-w94x.

Is CVE-2022-28220 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free