# CVE-2022-28220: STARTTLS command injection in Apache JAMES

> Attackers can exploit a parser differential in the STARTTLS command to inject commands, potentially leading to code execution on the mail server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-w45j-f5g5-w94x

## What is CVE-2022-28220?

CVE-2022-28220 is a high-severity command injection vulnerability in Apache James, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache James prior to release 3.6.3 and 3.7.1 is vulnerable to a buffering attack relying on the use of the STARTTLS command. Fix of CVE-2021-38542, which solved similar problem fron Apache James 3.6.1, is subject to a parser differential and do not take into account concurrent requests.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-28220?

4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 3.6.3 |
| `org.apache.james:james-server` | Maven | All versions | 3.6.3 |
| `org.apache.james:james-server` | Maven | From 3.7.0 | 3.7.1 |
| `org.apache.james:james-server` | Maven | From 3.7.0 | 3.7.1 |

Products: Apache James.

## How do I fix CVE-2022-28220?

Upgrade org.apache.james:james-server to a fixed version for your release line: 3.6.3 or 3.7.1.

## Is CVE-2022-28220 being exploited?

There is no known exploitation of CVE-2022-28220 in the wild and no public exploit code.

## Other vulnerabilities in Apache James

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28220 and fix it if it is affected.

What it is: CVE-2022-28220 is a high-severity command injection vulnerability in Apache James, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28220 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.3
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.3
- org.apache.james:james-server (Maven): affected from 3.7.0; fixed in 3.7.1
- org.apache.james:james-server (Maven): affected from 3.7.0; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28220/ (Markdown: https://insights.sbomify.com/CVE-2022-28220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28220
- OSV: https://osv.dev/vulnerability/CVE-2022-28220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28220/
Summaries are generated and may contain mistakes; the official description above is the record.
