CVE-2022-28224 Calico and Calico Enterprise may be vulnerable to route hijacking with the floating IP feature

Medium 5.5 Published Updated

A privileged attacker can hijack routes by setting floating IP annotations on pods, allowing traffic interception even when the feature is disabled.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-28224?

CVE-2022-28224 is a medium-severity missing authorization vulnerability in Project Calico Calico, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Clusters using Calico (version 3.22.1 and below), Calico Enterprise (version 3.12.0 and below), may be vulnerable to route hijacking with the floating IP feature. Due to insufficient validation, a privileged attacker may be able to set a floating IP annotation to a pod even if the feature is not enabled. This may allow the attacker to intercept and reroute traffic to their compromised pod.

Weakness: CWE-20, CWE-201, CWE-200

Which versions are affected by CVE-2022-28224?

6 open source packages ship an affected version, including github.com/projectcalico/calico. It affects 2 products.

PackageAffectedFixed in
github.com/projectcalico/calico GoAll versions3.20.5
github.com/projectcalico/calico GoAll versions3.20.5
github.com/projectcalico/calico GoFrom 3.21.03.21.5
github.com/projectcalico/calico GoFrom 3.21.03.21.5
github.com/projectcalico/calico GoFrom 3.22.03.22.2
github.com/projectcalico/calico GoFrom 3.22.03.22.2

Products include Tigera Calico, Tigera Calico Enterprise.

How do I fix CVE-2022-28224?

Upgrade github.com/projectcalico/calico to a fixed version for your release line: 3.20.5, 3.21.5 or 3.22.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-28224 being exploited?

There is no known exploitation of CVE-2022-28224 in the wild and no public exploit code.

Sources

Also known as GHSA-9394-xfq9-6qrp.

Is CVE-2022-28224 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free