# CVE-2022-28224: Calico and Calico Enterprise may be vulnerable to route hijacking with the floating IP feature

> A privileged attacker can hijack routes by setting floating IP annotations on pods, allowing traffic interception even when the feature is disabled.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9394-xfq9-6qrp

## What is CVE-2022-28224?

CVE-2022-28224 is a medium-severity missing authorization vulnerability in Project Calico Calico, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Clusters using Calico (version 3.22.1 and below), Calico Enterprise (version 3.12.0 and below), may be vulnerable to route hijacking with the floating IP feature. Due to insufficient validation, a privileged attacker may be able to set a floating IP annotation to a pod even if the feature is not enabled. This may allow the attacker to intercept and reroute traffic to their compromised pod.

Weakness: CWE-20 (Improper Input Validation), CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-28224?

6 open source packages ship an affected version, including github.com/projectcalico/calico. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/projectcalico/calico` | Go | All versions | 3.20.5 |
| `github.com/projectcalico/calico` | Go | All versions | 3.20.5 |
| `github.com/projectcalico/calico` | Go | From 3.21.0 | 3.21.5 |
| `github.com/projectcalico/calico` | Go | From 3.21.0 | 3.21.5 |
| `github.com/projectcalico/calico` | Go | From 3.22.0 | 3.22.2 |
| `github.com/projectcalico/calico` | Go | From 3.22.0 | 3.22.2 |

Products: Tigera Calico, Tigera Calico Enterprise.

## How do I fix CVE-2022-28224?

Upgrade github.com/projectcalico/calico to a fixed version for your release line: 3.20.5, 3.21.5 or 3.22.2.

## Is CVE-2022-28224 being exploited?

There is no known exploitation of CVE-2022-28224 in the wild and no public exploit code.

## Other vulnerabilities in Project Calico Calico

- [CVE-2026-6540](https://insights.sbomify.com/CVE-2026-6540/): L7 policy bypass via unnormalized HTTP path matching (high 7.9)
- [CVE-2026-41187](https://insights.sbomify.com/CVE-2026-41187/): Calico Tier Authorization Bypass via DeleteCollection (medium 6.2)
- [CVE-2026-41186](https://insights.sbomify.com/CVE-2026-41186/): Unauthenticated Go pprof exposure in Calico debug server (medium 6.0)
- [CVE-2026-41184](https://insights.sbomify.com/CVE-2026-41184/): ServiceAccount token disclosure via install-cni container logs (medium 6.0)
- [CVE-2026-41185](https://insights.sbomify.com/CVE-2026-41185/): ServiceAccount token disclosure via Azure IPAM CNI plugin logs (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28224 and fix it if it is affected.

What it is: CVE-2022-28224 is a medium-severity missing authorization vulnerability in Project Calico Calico, published on 6 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28224 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/projectcalico/calico (Go): affected all versions; fixed in 3.20.5
- github.com/projectcalico/calico (Go): affected all versions; fixed in 3.20.5
- github.com/projectcalico/calico (Go): affected from 3.21.0; fixed in 3.21.5
- github.com/projectcalico/calico (Go): affected from 3.21.0; fixed in 3.21.5
- github.com/projectcalico/calico (Go): affected from 3.22.0; fixed in 3.22.2
- github.com/projectcalico/calico (Go): affected from 3.22.0; fixed in 3.22.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28224/ (Markdown: https://insights.sbomify.com/CVE-2022-28224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28224
- OSV: https://osv.dev/vulnerability/CVE-2022-28224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28224/
Summaries are generated and may contain mistakes; the official description above is the record.
