CVE-2022-2826 Cross-site scripting in GitLab

Low 2.7 Published Updated

Cross-site scripting vulnerability in GitLab allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2826?

CVE-2022-2826 is a low-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 28 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 10.0 before 12.9.8, all versions starting from 12.10 before 12.10.7, all versions starting from 13.0 before 13.0.1. TODO

Weakness: CWE-79

Which versions are affected by CVE-2022-2826?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.0.012.9.8, 12.10.7, 13.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2826?

Upgrade gitlab to a fixed version for your release line: 12.9.8, 12.10.7 or 13.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2826 being exploited?

There is no known exploitation of CVE-2022-2826 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2826, GHSA-rwch-32vf-3m2v, UBUNTU-CVE-2022-2826.

Is CVE-2022-2826 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free