CVE-2022-28327 Denial of service in n/a

High 7.5 Published Updated

A remote attacker can cause a denial of service via a panic in the Go crypto/elliptic package by providing long scalar input to the generic P-256 feature.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-28327?

CVE-2022-28327 is a high-severity denial of service vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The generic P-256 feature in crypto/elliptic in Go before 1.17.9 and 1.18.x before 1.18.1 allows a panic via long scalar input.

Which versions are affected by CVE-2022-28327?

2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.

PackageAffectedFixed in
golang BitnamiAll versions1.17.9, 1.18.1
stdlib GoAll versions1.17.9, 1.18.1

Products include Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Golang Go.

How do I fix CVE-2022-28327?

Upgrade golang to a fixed version for your release line: 1.17.9 or 1.18.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-28327 being exploited?

There is no known exploitation of CVE-2022-28327 in the wild and no public exploit code.

All Fedoraproject Extra Packages for Enterprise Linux vulnerabilities

Sources

Also known as AZL-9547, BIT-golang-2022-28327, GHSA-v5qw-m6mv-3q79, GO-2022-0435, UBUNTU-CVE-2022-28327.

Is CVE-2022-28327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free