{"answers":{"affected":"2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-28327 in the wild and no public exploit code.","fix":"Upgrade golang to a fixed version for your release line: 1.17.9 or 1.18.1.","what":"CVE-2022-28327 is a high-severity denial of service vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28327 and fix it if it is affected.\n\nWhat it is: CVE-2022-28327 is a high-severity denial of service vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28327 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- golang (Bitnami): affected all versions; fixed in 1.17.9, 1.18.1\n- stdlib (Go): affected all versions; fixed in 1.17.9, 1.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28327/ (Markdown: https://insights.sbomify.com/CVE-2022-28327/index.md)","id":"CVE-2022-28327","markdown":"https://insights.sbomify.com/CVE-2022-28327/index.md","name":"CVE-2022-28327","record":{"aliases":["AZL-9547","BIT-golang-2022-28327","GHSA-v5qw-m6mv-3q79","GO-2022-0435","UBUNTU-CVE-2022-28327"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go standard library","requires_auth":"none","summary":"A remote attacker can cause a denial of service via a panic in the Go crypto/elliptic package by providing long scalar input to the generic P-256 feature.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"extra_packages_for_enterprise_linux","vendor":"fedoraproject"},{"product":"fedora","vendor":"fedoraproject"},{"product":"go","vendor":"golang"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"The generic P-256 feature in crypto/elliptic in Go before 1.17.9 and 1.18.x before 1.18.1 allows a panic via long scalar input.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-28327","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:extra_packages_for_enterprise_linux","products":["fedoraproject:extra_packages_for_enterprise_linux","fedoraproject:fedora","golang:go"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":12,"next":{"headline":"Denial of service in SCALANCE W1788-1 M12","id":"CVE-2022-28328"},"packages":[{"ecosystem":"Bitnami","fixed":["1.17.9","1.18.1"],"introduced":["0","1.18.0"],"last_affected":[],"package":"golang","purl":"pkg:bitnami/golang","source":"BIT-golang-2022-28327"},{"ecosystem":"Go","fixed":["1.17.9","1.18.1"],"introduced":["0","1.18.0-0"],"last_affected":[],"package":"stdlib","purl":"pkg:golang/stdlib","source":"GO-2022-0435"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2022-28323"},"products":["n/a"],"published":"2022-04-20","related":[{"cvss_score":9.8,"headline":"Command injection in ImageMagick","id":"CVE-2023-34152","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"Code injection in rxvt-unicode","id":"CVE-2022-4170","kev_date_added":null,"published":"2022-12-09"},{"cvss_score":9.8,"headline":"Moodle Minor SQL injection risk in admin user browsing","id":"CVE-2022-40315","kev_date_added":null,"published":"2022-09-30"},{"cvss_score":9.1,"headline":"Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library","id":"CVE-2022-45152","kev_date_added":null,"published":"2022-11-25"},{"cvss_score":9.1,"headline":"Server side NTLM does not properly check parameters in FreeRDP","id":"CVE-2022-24882","kev_date_added":null,"published":"2022-04-26"},{"cvss_score":8.8,"headline":"Use after free in Chrome","id":"CVE-2022-2158","kev_date_added":null,"published":"2022-07-28"},{"cvss_score":8.8,"headline":"Use after free in Chrome","id":"CVE-2022-2163","kev_date_added":null,"published":"2022-07-28"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A remote attacker can cause a denial of service via a panic in the Go crypto/elliptic package by providing long scalar input to the generic P-256 feature.","url":"https://insights.sbomify.com/CVE-2022-28327/"}