# CVE-2022-28327: Denial of service in n/a

> A remote attacker can cause a denial of service via a panic in the Go crypto/elliptic package by providing long scalar input to the generic P-256 feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-9547, BIT-golang-2022-28327, GHSA-v5qw-m6mv-3q79, GO-2022-0435, UBUNTU-CVE-2022-28327

## What is CVE-2022-28327?

CVE-2022-28327 is a high-severity denial of service vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The generic P-256 feature in crypto/elliptic in Go before 1.17.9 and 1.18.x before 1.18.1 allows a panic via long scalar input.

## Which versions are affected by CVE-2022-28327?

2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.17.9, 1.18.1 |
| `stdlib` | Go | All versions | 1.17.9, 1.18.1 |

Products: Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Golang Go.

## How do I fix CVE-2022-28327?

Upgrade golang to a fixed version for your release line: 1.17.9 or 1.18.1.

## Is CVE-2022-28327 being exploited?

There is no known exploitation of CVE-2022-28327 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux

- [CVE-2023-34152](https://insights.sbomify.com/CVE-2023-34152/): Command injection in ImageMagick (critical 9.8)
- [CVE-2022-4170](https://insights.sbomify.com/CVE-2022-4170/): Code injection in rxvt-unicode (critical 9.8)
- [CVE-2022-40315](https://insights.sbomify.com/CVE-2022-40315/): Moodle Minor SQL injection risk in admin user browsing (critical 9.8)
- [CVE-2022-45152](https://insights.sbomify.com/CVE-2022-45152/): Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library (critical 9.1)
- [CVE-2022-24882](https://insights.sbomify.com/CVE-2022-24882/): Server side NTLM does not properly check parameters in FreeRDP (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28327 and fix it if it is affected.

What it is: CVE-2022-28327 is a high-severity denial of service vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 20 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28327 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.17.9, 1.18.1
- stdlib (Go): affected all versions; fixed in 1.17.9, 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28327/ (Markdown: https://insights.sbomify.com/CVE-2022-28327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28327
- OSV: https://osv.dev/vulnerability/CVE-2022-28327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28327/
Summaries are generated and may contain mistakes; the official description above is the record.
