# CVE-2022-28346: SQL Injection in Django

> Attackers can execute arbitrary SQL commands via crafted dictionary arguments in Django QuerySet methods, potentially accessing or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-django-2022-28346, DEBIAN-CVE-2022-28346, DLA-2982-1, GHSA-2gwj-7jmv-h26r, PYSEC-2022-190, RHSA-2022:5115, UBUNTU-CVE-2022-28346

## What is CVE-2022-28346?

CVE-2022-28346 is a critical SQL injection vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. QuerySet.annotate(), aggregate(), and extra() methods are subject to SQL injection in column aliases via a crafted dictionary (with dictionary expansion) as the passed **kwargs.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-28346?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.28, 3.2.13, 4.0.4 |
| `django` | PyPI | From 2.2 | 2.2.28 |
| `django` | PyPI | From 3.2 | 3.2.13 |
| `django` | PyPI | From 4.0 | 4.0.4, 3.2.13, 2.2.28 |
| `django` | PyPI | From 4.0 | 4.0.4 |
| `Django` | PyPI | From 2.2 | 2.2.28 |
| `Django` | PyPI | From 3.2 | 3.2.13 |
| `Django` | PyPI | From 4.0 | 4.0.4 |
| `python-django20` | Red Hat:openstack:16.2::el8 | All versions | 0:2.0.13-17.el8ost |

Products: Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2022-28346?

Upgrade django to a fixed version for your release line: 2.2.28, 3.2.13 or 4.0.4.

## Is CVE-2022-28346 being exploited?

There is no known exploitation of CVE-2022-28346 in the wild and no public exploit code.

Public exploit code:

- Django QuerySet.annotate(), aggregate(), extra() SQL 注入 (github_poc): https://github.com/DeEpinGh0st/CVE-2022-28346
- SQL injection in QuerySet.annotate(), aggregate(), and extra() (github_poc): https://github.com/YouGina/CVE-2022-28346
- A flaw was found in the Django package, which leads to a SQL injection. This flaw allows an attacker using a crafted dictionary containing malicious SQL queries to compromise the database completely. (github_poc): https://github.com/kamal-marouane/CVE-2022-28346
- An issue was discovered in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. QuerySet.annotate(), aggregate(), and extra() methods are subject to SQL injection in column aliases via a crafted dictionary (with dictionary expansion) as the passed **kwargs. (github_poc): https://github.com/vincentinttsh/CVE-2022-28346

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28346 and fix it if it is affected.

What it is: CVE-2022-28346 is a critical SQL injection vulnerability in Debian Debian Linux, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28346 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.28, 3.2.13, 4.0.4
- django (PyPI): affected from 2.2; fixed in 2.2.28
- django (PyPI): affected from 3.2; fixed in 3.2.13
- django (PyPI): affected from 4.0; fixed in 4.0.4, 3.2.13, 2.2.28
- django (PyPI): affected from 4.0; fixed in 4.0.4
- Django (PyPI): affected from 2.2; fixed in 2.2.28
- Django (PyPI): affected from 3.2; fixed in 3.2.13
- Django (PyPI): affected from 4.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28346/ (Markdown: https://insights.sbomify.com/CVE-2022-28346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28346
- OSV: https://osv.dev/vulnerability/CVE-2022-28346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28346/
Summaries are generated and may contain mistakes; the official description above is the record.
