CVE-2022-28366 Denial of service in HtmlUnit-Neko
Attackers can cause denial of service via crafted Processing Instruction input leading to excessive heap memory consumption in Neko HTML parsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-28366?
CVE-2022-28366 is a high-severity denial of service vulnerability in n/a, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Which versions are affected by CVE-2022-28366?
2 open source packages ship an affected version, including net.sourceforge.htmlunit:neko-htmlunit. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
net.sourceforge.htmlunit:neko-htmlunit Maven | All versions | 2.27 |
net.sourceforge.htmlunit:neko-htmlunit Maven | All versions | 2.27 |
Products include Antisamy Project Antisamy, Cyberneko Html Project Cyberneko Html, Htmlunit Htmlunit.
How do I fix CVE-2022-28366?
Upgrade net.sourceforge.htmlunit:neko-htmlunit to 2.27 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-28366 being exploited?
There is no known exploitation of CVE-2022-28366 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as CVE-2022-29280, DEBIAN-CVE-2022-28366, GHSA-g9hh-vvx3-v37v, UBUNTU-CVE-2022-28366, openSUSE-SU-2024:12022-1.