{"answers":{"affected":"2 open source packages ship an affected version, including net.sourceforge.htmlunit:neko-htmlunit. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-28366 in the wild and no public exploit code.","fix":"Upgrade net.sourceforge.htmlunit:neko-htmlunit to 2.27 or later.","what":"CVE-2022-28366 is a high-severity denial of service vulnerability in n/a, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28366 and fix it if it is affected.\n\nWhat it is: CVE-2022-28366 is a high-severity denial of service vulnerability in n/a, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28366 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- net.sourceforge.htmlunit:neko-htmlunit (Maven): affected all versions; fixed in 2.27\n- net.sourceforge.htmlunit:neko-htmlunit (Maven): affected all versions; fixed in 2.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28366/ (Markdown: https://insights.sbomify.com/CVE-2022-28366/index.md)","id":"CVE-2022-28366","markdown":"https://insights.sbomify.com/CVE-2022-28366/index.md","name":"CVE-2022-28366","record":{"aliases":["CVE-2022-29280","DEBIAN-CVE-2022-28366","GHSA-g9hh-vvx3-v37v","UBUNTU-CVE-2022-28366","openSUSE-SU-2024:12022-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML parser library","requires_auth":"none","summary":"Attackers can cause denial of service via crafted Processing Instruction input leading to excessive heap memory consumption in Neko HTML parsers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"antisamy","vendor":"antisamy_project"},{"product":"cyberneko_html","vendor":"cyberneko_html_project"},{"product":"htmlunit","vendor":"htmlunit"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in HtmlUnit-Neko","id":"CVE-2022-28366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367"},"packages":[{"ecosystem":"Maven","fixed":["2.27"],"introduced":["0"],"last_affected":[],"package":"net.sourceforge.htmlunit:neko-htmlunit","purl":null,"source":"GHSA-g9hh-vvx3-v37v"},{"ecosystem":"Maven","fixed":["2.27"],"introduced":["0"],"last_affected":[],"package":"net.sourceforge.htmlunit:neko-htmlunit","purl":"pkg:maven/net.sourceforge.htmlunit/neko-htmlunit","source":"GHSA-g9hh-vvx3-v37v"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2022-28365"},"products":["n/a"],"published":"2022-04-21","related":[{"cvss_score":6.1,"headline":"AntiSamy malicious input can provoke XSS when preserving comments","id":"CVE-2024-23635","kev_date_added":null,"published":"2024-02-02"},{"cvss_score":6.1,"headline":"mXSS in AntiSamy","id":"CVE-2023-43643","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-29577","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2021-35043","kev_date_added":null,"published":"2021-07-19"},{"cvss_score":6.1,"headline":"OWASP AntiSamy Cross-site Scripting vulnerability","id":"CVE-2017-14735","kev_date_added":null,"published":"2017-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can cause denial of service via crafted Processing Instruction input leading to excessive heap memory consumption in Neko HTML parsers.","url":"https://insights.sbomify.com/CVE-2022-28366/"}