# CVE-2022-28378: Cross-site Scripting in craftcms/cms


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7xj5-fwqr-5378

## What is CVE-2022-28378?

CVE-2022-28378 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Apr 2022. 

### Official description

Craft CMS before 3.7.29 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-28378?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | All versions | 3.7.29 |
| `craftcms/cms` | Packagist | All versions | 3.7.29 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2022-28378?

Upgrade craftcms/cms to 3.7.29 or later.

## Is CVE-2022-28378 being exploited?

There is no known exploitation of CVE-2022-28378 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28378 and fix it if it is affected.

What it is: CVE-2022-28378 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Apr 2022. 
Exploitation: There is no known exploitation of CVE-2022-28378 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected all versions; fixed in 3.7.29
- craftcms/cms (Packagist): affected all versions; fixed in 3.7.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28378/ (Markdown: https://insights.sbomify.com/CVE-2022-28378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28378
- OSV: https://osv.dev/vulnerability/CVE-2022-28378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28378/
Summaries are generated and may contain mistakes; the official description above is the record.
