CVE-2022-2865 Cross-site scripting in GitLab

High 7.3 Published Updated

Stored XSS in GitLab label color settings allows attackers to perform arbitrary actions on behalf of victims.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2865?

CVE-2022-2865 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, 15.2 to 15.2.4 and 15.3 prior to 15.3.2. It was possible to exploit a vulnerability in setting the labels colour feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-2865?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.0.015.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-2865?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2865 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2865, GHSA-gw7r-3j53-5c25, UBUNTU-CVE-2022-2865.

Is CVE-2022-2865 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free