# CVE-2022-2865: Cross-site scripting in GitLab

> Stored XSS in GitLab label color settings allows attackers to perform arbitrary actions on behalf of victims.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Oct 2022
- **Updated:** 14 May 2025
- **Also known as:** BIT-gitlab-2022-2865, GHSA-gw7r-3j53-5c25, UBUNTU-CVE-2022-2865

## What is CVE-2022-2865?

CVE-2022-2865 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, 15.2 to 15.2.4 and 15.3 prior to 15.3.2. It was possible to exploit a vulnerability in setting the labels colour feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-2865?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 9.0.0 | 15.1.6, 15.2.4, 15.3.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-2865?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

## Is CVE-2022-2865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2865 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2865 and fix it if it is affected.

What it is: CVE-2022-2865 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2865 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 9.0.0; fixed in 15.1.6, 15.2.4, 15.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2865/ (Markdown: https://insights.sbomify.com/CVE-2022-2865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2865
- OSV: https://osv.dev/vulnerability/CVE-2022-2865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2865/
Summaries are generated and may contain mistakes; the official description above is the record.
