CVE-2022-2870 laravel deserialization
Remote attackers can exploit unsafe deserialization in Laravel to execute arbitrary code, requiring immediate framework upgrades.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2870?
CVE-2022-2870 is a medium-severity unsafe deserialization vulnerability in unspecified laravel, published on 17 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A vulnerability was found in laravel 5.1 and classified as problematic. This issue affects some unknown processing. The manipulation leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-206501 was assigned to this vulnerability.
Weakness: CWE-502
Which versions are affected by CVE-2022-2870?
1 open source package ship an affected version, including laravel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
laravel Bitnami | From 5.1.0 | 5.1.47 |
Products include Laravel Laravel.
How do I fix CVE-2022-2870?
Upgrade laravel to 5.1.47 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2022-2870 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2870 exists.
Other vulnerabilities in unspecified laravel
Sources
Also known as BIT-laravel-2022-2870, GHSA-g4q4-r6rr-r4w2.