{"answers":{"affected":"1 open source package ship an affected version, including laravel. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2870 exists.","fix":"Upgrade laravel to 5.1.47 or later.","what":"CVE-2022-2870 is a medium-severity unsafe deserialization vulnerability in unspecified laravel, published on 17 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2870 and fix it if it is affected.\n\nWhat it is: CVE-2022-2870 is a medium-severity unsafe deserialization vulnerability in unspecified laravel, published on 17 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2870 exists.\n\nAffected packages and fixed versions:\n- laravel (Bitnami): affected from 5.1.0; fixed in 5.1.47\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2870/ (Markdown: https://insights.sbomify.com/CVE-2022-2870/index.md)","id":"CVE-2022-2870","markdown":"https://insights.sbomify.com/CVE-2022-2870/index.md","name":"CVE-2022-2870","record":{"aliases":["BIT-laravel-2022-2870","GHSA-g4q4-r6rr-r4w2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel PHP framework","requires_auth":"high_privilege","summary":"Remote attackers can exploit unsafe deserialization in Laravel to execute arbitrary code, requiring immediate framework upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"laravel","vendor":"laravel"}],"cvss":{"score":4.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A vulnerability was found in laravel 5.1 and classified as problematic. This issue affects some unknown processing. The manipulation leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-206501 was assigned to this vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"laravel deserialization","id":"CVE-2022-2870","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":1,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Stored in notrinos/notrinoserp","id":"CVE-2022-2871"},"packages":[{"ecosystem":"Bitnami","fixed":["5.1.47"],"introduced":["5.1.0"],"last_affected":[],"package":"laravel","purl":"pkg:bitnami/laravel","source":"BIT-laravel-2022-2870"}],"prev":{"headline":"Integer overflow in libtiff","id":"CVE-2022-2869"},"products":["laravel"],"published":"2022-08-17","related":[{"cvss_score":8.1,"headline":"Laravel Deserialization of Untrusted Data","id":"CVE-2018-15133","kev_date_added":"2024-01-16","published":"2018-08-09"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2021-28254","kev_date_added":null,"published":"2023-04-18"},{"cvss_score":7.5,"headline":"Guard bypass in Eloquent models affecting Laravel illuminate database component","id":"CVE-2020-24940","kev_date_added":null,"published":"2020-09-04"},{"cvss_score":7.5,"headline":"Improper Input Validation in Laravel","id":"CVE-2020-24941","kev_date_added":null,"published":"2020-09-04"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2017-16894","kev_date_added":null,"published":"2017-11-20"},{"cvss_score":7.2,"headline":"Query Binding Exploitation in Laravel","id":"CVE-2021-21263","kev_date_added":null,"published":"2021-01-19"},{"cvss_score":6.1,"headline":"Laravel does not properly constrain the host portion of a password-reset URL","id":"CVE-2017-9303","kev_date_added":null,"published":"2017-05-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can exploit unsafe deserialization in Laravel to execute arbitrary code, requiring immediate framework upgrades.","url":"https://insights.sbomify.com/CVE-2022-2870/"}