# CVE-2022-28738: Use after free in n/a

> A double free in the Ruby Regexp compiler allows attackers to write to unexpected memory locations, potentially leading to code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-28738, BIT-ruby-2022-28738, BIT-ruby-min-2022-28738, CLEANSTART-2026-WY79580, GHSA-8pqg-8p79-j5j8, UBUNTU-CVE-2022-28738

## What is CVE-2022-28738?

CVE-2022-28738 is a critical use after free vulnerability in Ruby-Lang Ruby, published on 9 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2022-28738?

2 open source packages ship an affected version, including ruby and ruby-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby` | Bitnami | From 3.0.0 | 3.0.4, 3.1.2 |
| `ruby-min` | Bitnami | From 3.0.0 | 3.0.4, 3.1.2 |

Products: Ruby-Lang Ruby.

## How do I fix CVE-2022-28738?

Upgrade ruby to a fixed version for your release line: 3.0.4 or 3.1.2.

## Is CVE-2022-28738 being exploited?

There is no known exploitation of CVE-2022-28738 in the wild and no public exploit code.

## Other vulnerabilities in Ruby-Lang Ruby

- [CVE-2009-4124](https://insights.sbomify.com/CVE-2009-4124/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-4121](https://insights.sbomify.com/CVE-2011-4121/): Weak cryptography in OpenSSL extension of Ruby (Git trunk) (critical 9.8)
- [CVE-2017-17790](https://insights.sbomify.com/CVE-2017-17790/): Command injection in n/a (critical 9.8)
- [CVE-2017-11465](https://insights.sbomify.com/CVE-2017-11465/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-2336](https://insights.sbomify.com/CVE-2016-2336/): Memory corruption in Ruby (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28738 and fix it if it is affected.

What it is: CVE-2022-28738 is a critical use after free vulnerability in Ruby-Lang Ruby, published on 9 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28738 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby (Bitnami): affected from 3.0.0; fixed in 3.0.4, 3.1.2
- ruby-min (Bitnami): affected from 3.0.0; fixed in 3.0.4, 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28738/ (Markdown: https://insights.sbomify.com/CVE-2022-28738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28738
- OSV: https://osv.dev/vulnerability/CVE-2022-28738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28738/
Summaries are generated and may contain mistakes; the official description above is the record.
