# CVE-2022-28803: Stored XSS in link tags added via XHR in SilverStripe Framework

> Stored XSS in SilverStripe Framework allows attackers to inject malicious scripts via XHR link tags, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-silverstripe-2022-28803, GHSA-rppc-655v-7j3c

## What is CVE-2022-28803?

CVE-2022-28803 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 29 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In SilverStripe Framework through 2022-04-07, Stored XSS can occur in javascript link tags added via XMLHttpRequest (XHR).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-28803?

3 open source packages ship an affected version, including silverstripe/framework and silverstripe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.10.9 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.10.9 |
| `silverstripe` | Bitnami | All versions | 4.10.9 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2022-28803?

Upgrade silverstripe/framework to 4.10.9 or later.

## Is CVE-2022-28803 being exploited?

There is no known exploitation of CVE-2022-28803 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28803 and fix it if it is affected.

What it is: CVE-2022-28803 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 29 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-28803 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.10.9
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.10.9
- silverstripe (Bitnami): affected all versions; fixed in 4.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28803/ (Markdown: https://insights.sbomify.com/CVE-2022-28803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28803
- OSV: https://osv.dev/vulnerability/CVE-2022-28803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28803/
Summaries are generated and may contain mistakes; the official description above is the record.
