CVE-2022-2882 Server-side request forgery in GitLab

Medium 5.5 Published Updated

A malicious maintainer can exfiltrate GitHub integration access tokens by modifying the integration URL to send authenticated requests to an attacker-controlled server.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2882?

CVE-2022-2882 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 28 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. A malicious maintainer could exfiltrate a GitHub integration's access token by modifying the integration URL such that authenticated requests are sent to an attacker controlled server.

Weakness: CWE-668

Which versions are affected by CVE-2022-2882?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.6.015.2.5, 15.3.4, 15.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2882?

Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2022-2882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2882 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2882, GHSA-3mp9-x5q5-63w3, UBUNTU-CVE-2022-2882.

Is CVE-2022-2882 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free