{"answers":{"affected":"2 open source packages ship an affected version, including com.adobe.acs:acs-aem-commons. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-28820 in the wild and no public exploit code.","fix":"Upgrade com.adobe.acs:acs-aem-commons to 5.2.0 or later.","what":"CVE-2022-28820 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-28820 and fix it if it is affected.\n\nWhat it is: CVE-2022-28820 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-28820 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.adobe.acs:acs-aem-commons (Maven): affected all versions; fixed in 5.2.0\n- com.adobe.acs:acs-aem-commons (Maven): affected all versions; fixed in 5.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28820/ (Markdown: https://insights.sbomify.com/CVE-2022-28820/index.md)","id":"CVE-2022-28820","markdown":"https://insights.sbomify.com/CVE-2022-28820/index.md","name":"CVE-2022-28820","record":{"aliases":["CVE-2022-24874","GHSA-w5m2-299g-rff5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe AEM plugin","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in AEM Author users' browsers via reflected XSS in ACS Commons, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"acs_aem_commons","vendor":"adobe"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in /apps/acs-commons/content/page-compare.html endpoint via the a and b GET parameters. User input submitted via these parameters is not validated or sanitised. An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Adobe Consulting Services Reflected Cross-Site Scripting Arbitrary Code Execution","id":"CVE-2022-28820","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Adobe FrameMaker Font Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability","id":"CVE-2022-28821"},"packages":[{"ecosystem":"Maven","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"com.adobe.acs:acs-aem-commons","purl":null,"source":"GHSA-w5m2-299g-rff5"},{"ecosystem":"Maven","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"com.adobe.acs:acs-aem-commons","purl":"pkg:maven/com.adobe.acs/acs-aem-commons","source":"GHSA-w5m2-299g-rff5"}],"prev":{"headline":"Adobe Character Animator SVG File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability","id":"CVE-2022-28819"},"products":["Experience Manager"],"published":"2022-04-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Adobe"]},"summary":"Attackers can execute arbitrary JavaScript in AEM Author users' browsers via reflected XSS in ACS Commons, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2022-28820/"}