CVE-2022-2884 Command injection in GitLab
An authenticated user can achieve remote code execution via the Import from GitHub API endpoint in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2884?
CVE-2022-2884 is a critical command injection vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability in GitLab CE/EE affecting all versions from 11.3.4 prior to 15.1.5, 15.2 to 15.2.3, 15.3 to 15.3 to 15.3.1 allows an an authenticated user to achieve remote code execution via the Import from GitHub API endpoint
Weakness: CWE-78
Which versions are affected by CVE-2022-2884?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.3.4 | 15.1.5, 15.2.3, 15.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2884?
Upgrade gitlab to a fixed version for your release line: 15.1.5, 15.2.3 or 15.3.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-2884 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2884 exists.
Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2884, GHSA-mjcr-h6w7-xcx6, UBUNTU-CVE-2022-2884.