# CVE-2022-2886: Laravel deserialization

> Remote attackers can exploit unsafe deserialization in Laravel to execute arbitrary code, requiring immediate framework upgrades.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2022
- **Updated:** 15 Apr 2025
- **Also known as:** BIT-laravel-2022-2886, GHSA-7236-phg4-48mj

## What is CVE-2022-2886?

CVE-2022-2886 is a medium-severity unsafe deserialization vulnerability in unspecified Laravel, published on 19 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as critical, was found in Laravel 5.1. Affected is an unknown function. The manipulation leads to deserialization. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-206688.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-2886?

1 open source package ship an affected version, including laravel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel` | Bitnami | From 5.1.0 | 5.1.47 |

Products: Laravel Laravel.

## How do I fix CVE-2022-2886?

Upgrade laravel to 5.1.47 or later.

## Is CVE-2022-2886 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2886 exists.

## Other vulnerabilities in unspecified Laravel

- [CVE-2018-15133](https://insights.sbomify.com/CVE-2018-15133/): Laravel Deserialization of Untrusted Data (high 8.1, exploited in the wild)
- [CVE-2021-28254](https://insights.sbomify.com/CVE-2021-28254/): Deserialization in n/a (critical 9.8)
- [CVE-2020-24940](https://insights.sbomify.com/CVE-2020-24940/): Guard bypass in Eloquent models affecting Laravel illuminate database component (high 7.5)
- [CVE-2020-24941](https://insights.sbomify.com/CVE-2020-24941/): Improper Input Validation in Laravel (high 7.5)
- [CVE-2017-16894](https://insights.sbomify.com/CVE-2017-16894/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2886 and fix it if it is affected.

What it is: CVE-2022-2886 is a medium-severity unsafe deserialization vulnerability in unspecified Laravel, published on 19 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2886 exists.

Affected packages and fixed versions:
- laravel (Bitnami): affected from 5.1.0; fixed in 5.1.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2886/ (Markdown: https://insights.sbomify.com/CVE-2022-2886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2886
- OSV: https://osv.dev/vulnerability/CVE-2022-2886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2886/
Summaries are generated and may contain mistakes; the official description above is the record.
