# CVE-2022-28889: Clickjacking in the web console

> Attackers can trick users into clicking hidden elements in the Apache Druid web console due to missing security headers.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pgq7-jcj5-xx6h

## What is CVE-2022-28889?

CVE-2022-28889 is a medium-severity vulnerability in Apache Druid, published on 7 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2022-28889?

2 open source packages ship an affected version, including org.apache.druid:druid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.druid:druid` | Maven | All versions | 0.23.0 |
| `org.apache.druid:druid` | Maven | All versions | 0.23.0 |

Products: Apache Druid.

## How do I fix CVE-2022-28889?

Upgrade org.apache.druid:druid to 0.23.0 or later.

## Is CVE-2022-28889 being exploited?

There is no known exploitation of CVE-2022-28889 in the wild and no public exploit code.

## Other vulnerabilities in Apache Druid

- [CVE-2026-23906](https://insights.sbomify.com/CVE-2026-23906/): Apache Druid: Authentication Bypass via LDAP Anonymous Bind (critical 9.8)
- [CVE-2025-59390](https://insights.sbomify.com/CVE-2025-59390/): Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. (critical 9.8)
- [CVE-2021-26919](https://insights.sbomify.com/CVE-2021-26919/): Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. (high 8.8)
- [CVE-2021-25646](https://insights.sbomify.com/CVE-2021-25646/): Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. (high 8.8)
- [CVE-2024-45537](https://insights.sbomify.com/CVE-2024-45537/): Apache Druid: Users can provide MySQL JDBC properties not on allow list (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28889 and fix it if it is affected.

What it is: CVE-2022-28889 is a medium-severity vulnerability in Apache Druid, published on 7 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-28889 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.druid:druid (Maven): affected all versions; fixed in 0.23.0
- org.apache.druid:druid (Maven): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28889/ (Markdown: https://insights.sbomify.com/CVE-2022-28889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28889
- OSV: https://osv.dev/vulnerability/CVE-2022-28889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28889/
Summaries are generated and may contain mistakes; the official description above is the record.
