# CVE-2022-28890: Processing external DTDs

> An attacker can exploit the RDF/XML parser to retrieve external DTDs, potentially leading to data disclosure or denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-28890, GHSA-gchv-364h-r896, UBUNTU-CVE-2022-28890

## What is CVE-2022-28890?

CVE-2022-28890 is a critical vulnerability in Apache Jena, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the RDF/XML parser of Apache Jena allows an attacker to cause an external DTD to be retrieved. This issue affects Apache Jena version 4.4.0 and prior versions. Apache Jena 4.2.x and 4.3.x do not allow external entities.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-28890?

2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jena:jena` | Maven | From 4.4.0 | 4.5.0 |
| `org.apache.jena:jena` | Maven | From 4.4.0 | 4.5.0 |

Products: Apache Jena.

## How do I fix CVE-2022-28890?

Upgrade org.apache.jena:jena to 4.5.0 or later.

## Is CVE-2022-28890 being exploited?

There is no known exploitation of CVE-2022-28890 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jena

- [CVE-2025-50151](https://insights.sbomify.com/CVE-2025-50151/): Apache Jena: Configuration files uploaded by administrative users are not check properly (high 8.8)
- [CVE-2023-32200](https://insights.sbomify.com/CVE-2023-32200/): Apache Jena: Exposure of execution in script engine expressions. (high 8.8)
- [CVE-2025-49656](https://insights.sbomify.com/CVE-2025-49656/): Apache Jena: Administrative users can create files outside the server directory space via the admin UI (high 7.5)
- [CVE-2021-39239](https://insights.sbomify.com/CVE-2021-39239/): XML External Entity (XXE) vulnerability (high 7.5)
- [CVE-2023-22665](https://insights.sbomify.com/CVE-2023-22665/): Apache Jena: Exposure of arbitrary execution in script engine expressions. (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-28890 and fix it if it is affected.

What it is: CVE-2022-28890 is a critical vulnerability in Apache Jena, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-28890 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jena:jena (Maven): affected from 4.4.0; fixed in 4.5.0
- org.apache.jena:jena (Maven): affected from 4.4.0; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-28890/ (Markdown: https://insights.sbomify.com/CVE-2022-28890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-28890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-28890
- OSV: https://osv.dev/vulnerability/CVE-2022-28890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-28890/
Summaries are generated and may contain mistakes; the official description above is the record.
