{"answers":{"affected":"3 open source packages ship an affected version, including github.com/open-policy-agent/opa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-28946 in the wild and no public exploit code.","fix":"Upgrade github.com/open-policy-agent/opa to 0.40.0 or later.","what":"CVE-2022-28946 is a high-severity denial of service vulnerability in n/a, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-28946 and fix it if it is affected.\n\nWhat it is: CVE-2022-28946 is a high-severity denial of service vulnerability in n/a, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-28946 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/open-policy-agent/opa (Go): affected all versions; fixed in 0.40.0\n- github.com/open-policy-agent/opa (Go): affected all versions; fixed in 0.40.0\n- github.com/open-policy-agent/opa (Go): affected all versions; fixed in 0.40.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-28946/ (Markdown: https://insights.sbomify.com/CVE-2022-28946/index.md)","id":"CVE-2022-28946","markdown":"https://insights.sbomify.com/CVE-2022-28946/index.md","name":"CVE-2022-28946","record":{"aliases":["GHSA-x7f3-62pm-9p38","GO-2022-0587","openSUSE-SU-2024:12102-1","openSUSE-SU-2024:12128-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Open Policy Agent","requires_auth":"none","summary":"An attacker can cause a Denial of Service in Open Policy Agent by triggering out-of-range memory access during expression parsing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"open_policy_agent","vendor":"openpolicyagent"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"An issue in the component ast/parser.go of Open Policy Agent v0.39.0 causes the application to incorrectly interpret every expression, causing a Denial of Service (DoS) via triggering out-of-range memory access.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out of bounds memory access in github.com/open-policy-agent/opa","id":"CVE-2022-28946","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":5,"n_references":1,"next":{"headline":"gopkg.in/yaml.v3 Denial of Service","id":"CVE-2022-28948"},"packages":[{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa","purl":null,"source":"GHSA-x7f3-62pm-9p38"},{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa","purl":"pkg:golang/github.com/open-policy-agent/opa","source":"GHSA-x7f3-62pm-9p38"},{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa","purl":"pkg:golang/github.com/open-policy-agent/opa","source":"GO-2022-0587"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.15.6-1.1"],"introduced":["0"],"last_affected":[],"package":"starboard","purl":"pkg:rpm/opensuse/starboard\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12128-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.28.0-1.1"],"introduced":["0"],"last_affected":[],"package":"trivy","purl":"pkg:rpm/opensuse/trivy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12102-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2022-28945"},"products":["n/a"],"published":"2022-05-19","related":[{"cvss_score":7.5,"headline":"Denial of service in Open Policy Agent","id":"CVE-2022-33082","kev_date_added":null,"published":"2022-06-30"},{"cvss_score":7.4,"headline":"OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions","id":"CVE-2022-36085","kev_date_added":null,"published":"2022-09-08"},{"cvss_score":6.3,"headline":"Array literal misordering in github.com/open-policy-agent/opa","id":"CVE-2022-23628","kev_date_added":null,"published":"2022-02-09"},{"cvss_score":6.1,"headline":"OPA SMB Force-Authentication","id":"CVE-2024-8260","kev_date_added":null,"published":"2024-08-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can cause a Denial of Service in Open Policy Agent by triggering out-of-range memory access during expression parsing.","url":"https://insights.sbomify.com/CVE-2022-28946/"}