CVE-2022-28978 Liferay Portal and Liferay DXP Vulnerable to XSS in the Site Module
Remote attackers can inject arbitrary web script or HTML via user names in the Site module's membership administration page.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-28978?
CVE-2022-28978 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Stored cross-site scripting (XSS) vulnerability in the Site module's user membership administration page in Liferay Portal 7.0.1 through 7.4.1, and Liferay DXP 7.0 before fix pack 102, 7.1 before fix pack 26, 7.2 before fix pack 15, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML via the a user's name.
Weakness: CWE-79
Which versions are affected by CVE-2022-28978?
8 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay:com.liferay.site.memberships.web. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | From 7.0.0 | 7.0.10.fp102 |
com.liferay.portal:release.dxp.bom Maven | From 7.0.0 | 7.0.10.fp102 |
com.liferay.portal:release.dxp.bom Maven | From 7.1.0 | 7.1.10.fp26 |
com.liferay.portal:release.dxp.bom Maven | From 7.1.0 | 7.1.10.fp26 |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp15 |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp15 |
2 more packages
com.liferay:com.liferay.site.memberships.web Maven | All versions | 5.0.10 |
com.liferay:com.liferay.site.memberships.web Maven | All versions | 5.0.10 |
Products include Liferay Digital Experience Platform, Liferay Dxp, Liferay Liferay Portal.
How do I fix CVE-2022-28978?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.0.10.fp102, 7.1.10.fp26 or 7.2.10.fp15.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-28978 being exploited?
There is no known exploitation of CVE-2022-28978 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Sources
Also known as GHSA-7m65-hmvg-rxpc.