# CVE-2022-29037: Stored XSS in Jenkins CVS Plugin

> Stored XSS in Jenkins CVS Plugin allows attackers with Item/Configure permission to execute arbitrary scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-ghq2-m3pq-qf3p

## What is CVE-2022-29037?

CVE-2022-29037 is a medium-severity cross-site scripting vulnerability in Jenkins CVS Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins CVS Plugin 2.19 and earlier does not escape the name and description of CVS Symbolic Name parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29037?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:cvs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:cvs` | Maven | All versions | 2.19.1 |
| `org.jenkins-ci.plugins:cvs` | Maven | All versions | 2.19.1 |

Products: Jenkins Cvs.

## How do I fix CVE-2022-29037?

Upgrade org.jenkins-ci.plugins:cvs to 2.19.1 or later.

## Is CVE-2022-29037 being exploited?

There is no known exploitation of CVE-2022-29037 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins CVS Plugin

- [CVE-2020-2324](https://insights.sbomify.com/CVE-2020-2324/): XXE vulnerability in Jenkins CVS Plugin (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29037 and fix it if it is affected.

What it is: CVE-2022-29037 is a medium-severity cross-site scripting vulnerability in Jenkins CVS Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29037 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:cvs (Maven): affected all versions; fixed in 2.19.1
- org.jenkins-ci.plugins:cvs (Maven): affected all versions; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29037/ (Markdown: https://insights.sbomify.com/CVE-2022-29037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29037
- OSV: https://osv.dev/vulnerability/CVE-2022-29037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29037/
Summaries are generated and may contain mistakes; the official description above is the record.
