CVE-2022-2904 Cross-site scripting in GitLab

High 7.3 Published Updated

Stored XSS in GitLab's external status checks allows attackers to perform arbitrary actions on behalf of victims.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2904?

CVE-2022-2904 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 2 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions starting from 15.2 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 It was possible to exploit a vulnerability in the external status checks feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-2904?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.2.015.2.5, 15.3.4, 15.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2904?

Upgrade gitlab to a fixed version for your release line: 15.2.5, 15.3.4 or 15.4.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2904 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2904 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2904, GHSA-pfg9-h349-wqvq, UBUNTU-CVE-2022-2904.

Is CVE-2022-2904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free