{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.tools:git-parameter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29040 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.tools:git-parameter to 0.9.16 or later.","what":"CVE-2022-29040 is a medium-severity cross-site scripting vulnerability in Jenkins Git Parameter Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29040 and fix it if it is affected.\n\nWhat it is: CVE-2022-29040 is a medium-severity cross-site scripting vulnerability in Jenkins Git Parameter Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29040 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.tools:git-parameter (Maven): affected all versions; fixed in 0.9.16\n- org.jenkins-ci.tools:git-parameter (Maven): affected all versions; fixed in 0.9.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29040/ (Markdown: https://insights.sbomify.com/CVE-2022-29040/index.md)","id":"CVE-2022-29040","markdown":"https://insights.sbomify.com/CVE-2022-29040/index.md","name":"CVE-2022-29040","record":{"aliases":["GHSA-fcr6-6cph-vmcm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git Parameter Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Git Parameter Plugin allows attackers with configure permissions to execute scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"git_parameter","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Git Parameter Plugin","id":"CVE-2022-29040","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Stored Cross-site Scripting vulnerability in Jenkins Jira Plugin","id":"CVE-2022-29041"},"packages":[{"ecosystem":"Maven","fixed":["0.9.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.tools:git-parameter","purl":null,"source":"GHSA-fcr6-6cph-vmcm"},{"ecosystem":"Maven","fixed":["0.9.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.tools:git-parameter","purl":"pkg:maven/org.jenkins-ci.tools/git-parameter","source":"GHSA-fcr6-6cph-vmcm"}],"prev":{"headline":"Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin","id":"CVE-2022-29039"},"products":["Jenkins Git Parameter Plugin"],"published":"2022-04-12","related":[{"cvss_score":8.2,"headline":"Jenkins Git Parameter Plugin vulnerable to code injection due to inexhaustive parameter check","id":"CVE-2025-53652","kev_date_added":null,"published":"2025-07-09"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins Git Parameter Plugin","id":"CVE-2020-2238","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":5.4,"headline":"Jenkins Git Parameter Plugin vulnerable to Stored cross-site scripting (XSS)","id":"CVE-2020-2112","kev_date_added":null,"published":"2020-02-12"},{"cvss_score":5.4,"headline":"Jenkins Git Parameter Plugin vulnerable to stored cross-site scripting (XSS)","id":"CVE-2020-2113","kev_date_added":null,"published":"2020-02-12"},{"cvss_score":4.3,"headline":"Jenkins Git Parameter Plugin has a missing permission check that allows listing SCM branch and tag names","id":"CVE-2026-57286","kev_date_added":null,"published":"2026-06-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Git Parameter Plugin allows attackers with configure permissions to execute scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2022-29040/"}