{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.plugins:jira. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29041 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:jira to a fixed version for your release line: 3.6.1 or 3.7.1.","what":"CVE-2022-29041 is a medium-severity cross-site scripting vulnerability in Jenkins Jira Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29041 and fix it if it is affected.\n\nWhat it is: CVE-2022-29041 is a medium-severity cross-site scripting vulnerability in Jenkins Jira Plugin, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29041 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:jira (Maven): affected all versions; fixed in 3.6.1\n- org.jenkins-ci.plugins:jira (Maven): affected all versions; fixed in 3.6.1\n- org.jenkins-ci.plugins:jira (Maven): affected from 3.7.0; fixed in 3.7.1\n- org.jenkins-ci.plugins:jira (Maven): affected from 3.7.0; fixed in 3.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29041/ (Markdown: https://insights.sbomify.com/CVE-2022-29041/index.md)","id":"CVE-2022-29041","markdown":"https://insights.sbomify.com/CVE-2022-29041/index.md","name":"CVE-2022-29041","record":{"aliases":["GHSA-m3p3-2gp6-ghq8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Jira Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Jira Plugin allows attackers with configure permissions to inject scripts via issue parameters, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"jira","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Jira Plugin","id":"CVE-2022-29041","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Stored Cross-site Scripting vulnerability in Jenkins Job Generator Plugin","id":"CVE-2022-29042"},"packages":[{"ecosystem":"Maven","fixed":["3.6.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jira","purl":null,"source":"GHSA-m3p3-2gp6-ghq8"},{"ecosystem":"Maven","fixed":["3.6.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jira","purl":"pkg:maven/org.jenkins-ci.plugins/jira","source":"GHSA-m3p3-2gp6-ghq8"},{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["3.7.0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jira","purl":null,"source":"GHSA-m3p3-2gp6-ghq8"},{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["3.7.0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jira","purl":"pkg:maven/org.jenkins-ci.plugins/jira","source":"GHSA-m3p3-2gp6-ghq8"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Git Parameter Plugin","id":"CVE-2022-29040"},"products":["Jenkins Jira Plugin"],"published":"2022-04-12","related":[{"cvss_score":9.9,"headline":"Jenkins JIRA Plugin allows users to select and use credentials with System scope","id":"CVE-2019-16541","kev_date_added":null,"published":"2019-11-21"},{"cvss_score":8.8,"headline":"Jenkins Jira Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000412","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":6.5,"headline":"Jenkins Jira Plugin vulnerable to exposure of system-scoped credentials","id":"CVE-2023-49653","kev_date_added":null,"published":"2023-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Jira Plugin allows attackers with configure permissions to inject scripts via issue parameters, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2022-29041/"}