# CVE-2022-29046: Stored Cross-site Scripting vulnerability in Jenkins Subversion Plugin

> Stored XSS in Jenkins Subversion Plugin allows attackers with Item/Configure permission to execute scripts in other users' browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wpr6-qvcq-8269

## What is CVE-2022-29046?

CVE-2022-29046 is a medium-severity cross-site scripting vulnerability in Apple Macos, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Subversion Plugin 2.15.3 and earlier does not escape the name and description of List Subversion tags (and more) parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29046?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.15.4 |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.15.4 |

Products: Apple Macos, Jenkins Subversion.

## How do I fix CVE-2022-29046?

Upgrade org.jenkins-ci.plugins:subversion to 2.15.4 or later.

## Is CVE-2022-29046 being exploited?

There is no known exploitation of CVE-2022-29046 in the wild and no public exploit code.

## Other vulnerabilities in Apple Macos

- [CVE-2026-65400](https://insights.sbomify.com/CVE-2026-65400/): Apple macOS Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2024-44146](https://insights.sbomify.com/CVE-2024-44146/): Security feature bypass in macOS (critical 10.0)
- [CVE-2024-44148](https://insights.sbomify.com/CVE-2024-44148/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-38586](https://insights.sbomify.com/CVE-2023-38586/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-40455](https://insights.sbomify.com/CVE-2023-40455/): Security feature bypass in macOS (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29046 and fix it if it is affected.

What it is: CVE-2022-29046 is a medium-severity cross-site scripting vulnerability in Apple Macos, published on 12 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29046 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.15.4
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29046/ (Markdown: https://insights.sbomify.com/CVE-2022-29046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29046
- OSV: https://osv.dev/vulnerability/CVE-2022-29046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29046/
Summaries are generated and may contain mistakes; the official description above is the record.
