{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-29048 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:subversion to 2.15.4 or later.","what":"CVE-2022-29048 is a medium-severity vulnerability in Apple Macos, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29048 and fix it if it is affected.\n\nWhat it is: CVE-2022-29048 is a medium-severity vulnerability in Apple Macos, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.15.4\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.15.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29048/ (Markdown: https://insights.sbomify.com/CVE-2022-29048/index.md)","id":"CVE-2022-29048","markdown":"https://insights.sbomify.com/CVE-2022-29048/index.md","name":"CVE-2022-29048","record":{"aliases":["GHSA-m5cw-c64p-77h6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Subversion Plugin","requires_auth":"none","summary":"Attackers can force users to connect to malicious URLs via CSRF in the Jenkins Subversion Plugin, requiring plugin updates.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"macos","vendor":"apple"},{"product":"subversion","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Subversion Plugin","id":"CVE-2022-29048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apple:macos","products":["apple:macos"],"type":"csrf","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Promotion names in Jenkins promoted builds Plugin are not validated when using Job DSL","id":"CVE-2022-29049"},"packages":[{"ecosystem":"Maven","fixed":["2.15.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":null,"source":"GHSA-m5cw-c64p-77h6"},{"ecosystem":"Maven","fixed":["2.15.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":"pkg:maven/org.jenkins-ci.plugins/subversion","source":"GHSA-m5cw-c64p-77h6"}],"prev":{"headline":"Untrusted users can modify some Pipeline libraries in Jenkins Pipeline: Deprecated Groovy Libraries Plugin","id":"CVE-2022-29047"},"products":["Jenkins Subversion Plugin"],"published":"2022-04-12","related":[{"cvss_score":9.8,"headline":"Apple macOS Improper Authentication","id":"CVE-2026-65400","kev_date_added":"2026-08-18","published":"2026-08-06"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2024-44146","kev_date_added":null,"published":"2024-09-16"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2024-44148","kev_date_added":null,"published":"2024-09-16"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2023-38586","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2023-40455","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-1999-0590","kev_date_added":null,"published":"2000-02-04"},{"cvss_score":9.8,"headline":"Memory corruption in macOS","id":"CVE-2026-84520","kev_date_added":null,"published":"2026-09-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-20","vendors":["Jenkins project"]},"summary":"Attackers can force users to connect to malicious URLs via CSRF in the Jenkins Subversion Plugin, requiring plugin updates.","url":"https://insights.sbomify.com/CVE-2022-29048/"}