{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-ftp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29050 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:publish-over-ftp to 1.17 or later.","what":"CVE-2022-29050 is a high-severity vulnerability in Jenkins Publish Over FTP Plugin, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29050 and fix it if it is affected.\n\nWhat it is: CVE-2022-29050 is a high-severity vulnerability in Jenkins Publish Over FTP Plugin, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29050 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:publish-over-ftp (Maven): affected all versions; fixed in 1.17\n- org.jenkins-ci.plugins:publish-over-ftp (Maven): affected all versions; fixed in 1.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29050/ (Markdown: https://insights.sbomify.com/CVE-2022-29050/index.md)","id":"CVE-2022-29050","markdown":"https://insights.sbomify.com/CVE-2022-29050/index.md","name":"CVE-2022-29050","record":{"aliases":["GHSA-6w39-qhmq-g8cp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins FTP plugin","requires_auth":"none","summary":"Attackers can force users to connect to malicious FTP servers via CSRF in the Jenkins Publish Over FTP Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"publish_over_ftp","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Publish Over FTP Plugin 1.16 and earlier allows attackers to connect to an FTP server using attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Publish Over FTP Plugin","id":"CVE-2022-29050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Missing permission checks in Jenkins Publish Over FTP Plugin","id":"CVE-2022-29051"},"packages":[{"ecosystem":"Maven","fixed":["1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:publish-over-ftp","purl":null,"source":"GHSA-6w39-qhmq-g8cp"},{"ecosystem":"Maven","fixed":["1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:publish-over-ftp","purl":"pkg:maven/org.jenkins-ci.plugins/publish-over-ftp","source":"GHSA-6w39-qhmq-g8cp"}],"prev":{"headline":"Promotion names in Jenkins promoted builds Plugin are not validated when using Job DSL","id":"CVE-2022-29049"},"products":["Jenkins Publish Over FTP Plugin"],"published":"2022-04-12","related":[{"cvss_score":4.3,"headline":"Missing permission checks in Jenkins Publish Over FTP Plugin","id":"CVE-2022-29051","kev_date_added":null,"published":"2022-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can force users to connect to malicious FTP servers via CSRF in the Jenkins Publish Over FTP Plugin.","url":"https://insights.sbomify.com/CVE-2022-29050/"}