CVE-2022-2907 Information disclosure in GitLab

Medium 5.7 Published Updated

An unauthorized user can read repository content if a project member clicks a crafted link, exposing sensitive data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2907?

CVE-2022-2907 is a medium-severity vulnerability in Gitlab Gitlab, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. It was possible to read repository content by an unauthorised user if a project member used a crafted link.

Weakness: CWE-200

Which versions are affected by CVE-2022-2907?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.015.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-2907?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Is CVE-2022-2907 being exploited?

There is no known exploitation of CVE-2022-2907 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2907, GHSA-997f-v4rm-9w7m, UBUNTU-CVE-2022-2907.

Is CVE-2022-2907 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free