# CVE-2022-29078: ejs template injection vulnerability

> Attackers can execute arbitrary OS commands via server-side template injection in the EJS library, requiring immediate upgrades.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-29078, GHSA-phwq-j96m-2c2q, ROOT-APP-NPM-CVE-2022-29078, UBUNTU-CVE-2022-29078

## What is CVE-2022-29078?

CVE-2022-29078 is a critical code injection vulnerability in n/a, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ejs (aka Embedded JavaScript templates) package 3.1.6 for Node.js allows server-side template injection in settings[view options][outputFunctionName]. This is parsed as an internal option, and overwrites the outputFunctionName option with an arbitrary OS command (which is executed upon template compilation).

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-29078?

2 open source packages ship an affected version, including ejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ejs` | npm | All versions | 3.1.7 |
| `ejs` | npm | All versions | 3.1.7 |

Products: Ejs Ejs.

## How do I fix CVE-2022-29078?

Upgrade ejs to 3.1.7 or later.

## Is CVE-2022-29078 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29078 exists.

Public exploit code:

- vuln ejs 3.1.6 docker (github_poc): https://github.com/miko550/CVE-2022-29078
- Serverside Template Injection (SSTI) RCE - THM challenge "whiterose"     (github_poc): https://github.com/l0n3m4n/CVE-2022-29078
- https://github.com/shurochka1396/expluatation_CVE-2022-29078 (github_poc): https://github.com/shurochka1396/expluatation_CVE-2022-29078
- PoC for CVE-2022-29078 (github_poc): https://github.com/chuckdu21/CVE-2022-29078
- Browser demo: EJS template injection (CVE-2022-29078) with Seal Security remediation (github_poc): https://github.com/AlonNavon/npm-demo
- https://github.com/amusedx/CVE-2022-29078 (github_poc): https://github.com/amusedx/CVE-2022-29078

## Other vulnerabilities in n/a

- [CVE-2023-29827](https://insights.sbomify.com/CVE-2023-29827/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000228](https://insights.sbomify.com/CVE-2017-1000228/): ejs is vulnerable to remote code execution due to weak input validation (critical 9.8)
- [CVE-2017-1000189](https://insights.sbomify.com/CVE-2017-1000189/): ejs vulnerable to DoS due to weak input validation (high 7.5)
- [CVE-2017-1000188](https://insights.sbomify.com/CVE-2017-1000188/): mde ejs vulnerable to XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29078 and fix it if it is affected.

What it is: CVE-2022-29078 is a critical code injection vulnerability in n/a, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29078 exists.

Affected packages and fixed versions:
- ejs (npm): affected all versions; fixed in 3.1.7
- ejs (npm): affected all versions; fixed in 3.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29078/ (Markdown: https://insights.sbomify.com/CVE-2022-29078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29078
- OSV: https://osv.dev/vulnerability/CVE-2022-29078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29078/
Summaries are generated and may contain mistakes; the official description above is the record.
