CVE-2022-2908 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can cause high CPU usage and denial of service by submitting specially crafted input in the Commit message field.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2908?

CVE-2022-2908 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A potential DoS vulnerability was discovered in Gitlab CE/EE versions starting from 10.7 before 15.1.5, all versions starting from 15.2 before 15.2.3, all versions starting from 15.3 before 15.3.1 allowed an attacker to trigger high CPU usage via a special crafted input added in the Commit message field.

Weakness: CWE-1333

Which versions are affected by CVE-2022-2908?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.7.015.1.5, 15.2.3, 15.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2908?

Upgrade gitlab to a fixed version for your release line: 15.1.5, 15.2.3 or 15.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-2908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2908 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2908, GHSA-hxc7-qjfv-5432, UBUNTU-CVE-2022-2908.

Is CVE-2022-2908 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free