# CVE-2022-29153: Hashicorp Consul HTTP health check endpoints returning an HTTP redirect may be abused as SSRF vector

> Attackers can exploit HTTP health check redirects in Consul to perform server-side request forgery, potentially accessing internal resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-consul-2022-29153, DEBIAN-CVE-2022-29153, GHSA-q6h7-4qgw-2j9p, GO-2022-0615, UBUNTU-CVE-2022-29153

## What is CVE-2022-29153?

CVE-2022-29153 is a high-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise up to 1.9.16, 1.10.9, and 1.11.4 may allow server side request forgery when the Consul client agent follows redirects returned by HTTP health check endpoints. Fixed in 1.9.17, 1.10.10, and 1.11.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-29153?

8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.9.17, 1.10.10, 1.11.5 |
| `github.com/hashicorp/consul` | Go | All versions | 1.9.17 |
| `github.com/hashicorp/consul` | Go | All versions | 1.9.17 |
| `github.com/hashicorp/consul` | Go | From 1.10.0 | 1.10.10 |
| `github.com/hashicorp/consul` | Go | From 1.10.0 | 1.10.10 |
| `github.com/hashicorp/consul` | Go | From 1.11.0 | 1.11.5 |
| `github.com/hashicorp/consul` | Go | From 1.11.0 | 1.11.5 |
| `consul` | Bitnami | All versions | 1.9.17, 1.10.10, 1.11.5 |

Products: Fedoraproject Fedora, Hashicorp Consul.

## How do I fix CVE-2022-29153?

Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.9.17, 1.10.10 or 1.11.5.

## Is CVE-2022-29153 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29153 exists.

Public exploit code:

- HashiCorp Consul/Consul Enterprise - Server-Side Request Forgery (nuclei): http/cves/2022/CVE-2022-29153.yaml

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29153 and fix it if it is affected.

What it is: CVE-2022-29153 is a high-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29153 exists.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.9.17, 1.10.10, 1.11.5
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.9.17
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.9.17
- github.com/hashicorp/consul (Go): affected from 1.10.0; fixed in 1.10.10
- github.com/hashicorp/consul (Go): affected from 1.10.0; fixed in 1.10.10
- github.com/hashicorp/consul (Go): affected from 1.11.0; fixed in 1.11.5
- github.com/hashicorp/consul (Go): affected from 1.11.0; fixed in 1.11.5
- consul (Bitnami): affected all versions; fixed in 1.9.17, 1.10.10, 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29153/ (Markdown: https://insights.sbomify.com/CVE-2022-29153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29153
- OSV: https://osv.dev/vulnerability/CVE-2022-29153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29153/
Summaries are generated and may contain mistakes; the official description above is the record.
