CVE-2022-29158 Regular Expression Denial of Service (ReDoS) vulnerability in Apache OFBiz
Unauthenticated attackers can cause a denial of service in Apache OFBiz by sending specially crafted URLs that trigger excessive regular expression processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-29158?
CVE-2022-29158 is a high-severity denial of service vulnerability in Apache Ofbiz, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache OFBiz up to version 18.12.05 is vulnerable to Regular Expression Denial of Service (ReDoS) in the way it handles URLs provided by external, unauthenticated users. Upgrade to 18.12.06 or apply patches at https://issues.apache.org/jira/browse/OFBIZ-12599
Weakness: CWE-1333
Which versions are affected by CVE-2022-29158?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2022-29158?
No fix has been published for CVE-2022-29158 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-29158 being exploited?
There is no known exploitation of CVE-2022-29158 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-7hxq-2vp3-4xmj.