# CVE-2022-29161: Crypto script service uses hashing algorithm SHA1 with RSA for certificate signature in xwiki-platform

> XWiki generates certificates using weak SHA1 hashing, allowing potential signature collisions and security bypasses; administrators should upgrade to patched versions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-h8v5-p258-pqf4

## What is CVE-2022-29161?

CVE-2022-29161 is a medium-severity vulnerability in Xwiki Xwiki, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. The XWiki Crypto API will generate X509 certificates signed by default using SHA1 with RSA, which is not considered safe anymore for use in certificate signatures, due to the risk of collisions with SHA1. The problem has been patched in XWiki version 13.10.6, 14.3.1 and 14.4-rc-1. Since then, the Crypto API will generate X509 certificates signed by default using SHA256 with RSA. Administrators are advised to upgrade their XWiki installation to one of the patched versions. If the upgrade is not possible, it is possible to patch the module xwiki-platform-crypto in a local installation by applying the change exposed in 26728f3 and re-compiling the module.

Weakness: CWE-326 (Inadequate Encryption Strength), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2022-29161?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-crypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-crypto` | Maven | All versions | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-crypto` | Maven | All versions | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-crypto` | Maven | From 14.0.0 | 14.3.1 |
| `org.xwiki.platform:xwiki-platform-crypto` | Maven | From 14.0.0 | 14.3.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-29161?

Upgrade org.xwiki.platform:xwiki-platform-crypto to a fixed version for your release line: 13.10.6 or 14.3.1.

## Is CVE-2022-29161 being exploited?

There is no known exploitation of CVE-2022-29161 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29161 and fix it if it is affected.

What it is: CVE-2022-29161 is a medium-severity vulnerability in Xwiki Xwiki, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29161 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-crypto (Maven): affected all versions; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-crypto (Maven): affected all versions; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-crypto (Maven): affected from 14.0.0; fixed in 14.3.1
- org.xwiki.platform:xwiki-platform-crypto (Maven): affected from 14.0.0; fixed in 14.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29161/ (Markdown: https://insights.sbomify.com/CVE-2022-29161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29161
- OSV: https://osv.dev/vulnerability/CVE-2022-29161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29161/
Summaries are generated and may contain mistakes; the official description above is the record.
