# CVE-2022-29162: Incorrect Default Permissions in runc

> Attackers can exploit incorrect default permissions in runc exec to elevate capabilities, requiring specific command-line flags to trigger.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ALSA-2022:8090, AZL-9817, CLEANSTART-2026-CQ48087, DEBIAN-CVE-2022-29162, GHSA-f3fp-gc8g-vw66, GO-2022-0452, MGASA-2022-0192, OESA-2022-1704, RHSA-2022:8090, RLSA-2022:8090, UBUNTU-CVE-2022-29162

## What is CVE-2022-29162?

CVE-2022-29162 is a medium-severity vulnerability in Fedoraproject Fedora, published on 17 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

runc is a CLI tool for spawning and running containers on Linux according to the OCI specification. A bug was found in runc prior to version 1.1.2 where `runc exec --cap` created processes with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during execve(2). This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set. This bug has been fixed in runc 1.1.2. This fix changes `runc exec --cap` behavior such that the additional capabilities granted to the process being executed (as specified via `--cap` arguments) do not include inheritable capabilities. In addition, `runc spec` is changed to not set any inheritable capabilities in the created example OCI spec (`config.json`) file.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2022-29162?

3 open source packages ship an affected version, including github.com/opencontainers/runc. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.2 |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.2 |
| `github.com/opencontainers/runc` | Go | All versions | 1.1.2 |
| `runc` | AlmaLinux:9 | All versions | 4:1.1.4-1.el9 |
| `runc` | Red Hat:enterprise_linux:9::appstream | All versions | 4:1.1.4-1.el9 |
| `runc-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 4:1.1.4-1.el9 |
| `runc-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 4:1.1.4-1.el9 |
| `runc` | Rocky Linux:9 | All versions | 4:1.1.4-1.el9_1 |

Products: Fedoraproject Fedora, Linuxfoundation Runc.

## How do I fix CVE-2022-29162?

Upgrade github.com/opencontainers/runc to 1.1.2 or later.

## Is CVE-2022-29162 being exploited?

There is no known exploitation of CVE-2022-29162 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29162 and fix it if it is affected.

What it is: CVE-2022-29162 is a medium-severity vulnerability in Fedoraproject Fedora, published on 17 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29162 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.2
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.2
- github.com/opencontainers/runc (Go): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29162/ (Markdown: https://insights.sbomify.com/CVE-2022-29162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29162
- OSV: https://osv.dev/vulnerability/CVE-2022-29162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29162/
Summaries are generated and may contain mistakes; the official description above is the record.
