# CVE-2022-29170: Grafana Enterprise datasource network restrictions bypass via HTTP redirects

> Attackers can bypass network restrictions in Grafana Enterprise by using malicious datasource redirects to access forbidden hosts and potentially leak sensitive information.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-grafana-2022-29170, GHSA-9rrr-6fq2-4f99, OESA-2022-1711

## What is CVE-2022-29170?

CVE-2022-29170 is a medium-severity server-side request forgery vulnerability in Grafana Grafana, published on 20 May 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. In Grafana Enterprise, the Request security feature allows list allows to configure Grafana in a way so that the instance doesn’t call or only calls specific hosts. The vulnerability present starting with version 7.4.0-beta1 and prior to versions 7.5.16 and 8.5.3 allows someone to bypass these security configurations if a malicious datasource (running on an allowed host) returns an HTTP redirect to a forbidden host. The vulnerability only impacts Grafana Enterprise when the Request security allow list is used and there is a possibility to add a custom datasource to Grafana which returns HTTP redirects. In this scenario, Grafana would blindly follow the redirects and potentially give secure information to the clients. Grafana Cloud is not impacted by this vulnerability. Versions 7.5.16 and 8.5.3 contain a patch for this issue. There are currently no known workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-29170?

1 open source package ship an affected version, including grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana` | Bitnami | From 7.4.0 | 7.5.16, 8.5.3 |

Products: Grafana Grafana.

## How do I fix CVE-2022-29170?

Upgrade grafana to a fixed version for your release line: 7.5.16 or 8.5.3.

## Is CVE-2022-29170 being exploited?

There is no known exploitation of CVE-2022-29170 in the wild and no public exploit code.

Public exploit code:

- Grafana is an open-source platform for monitoring and observability. In Grafana Enterprise, the Request security feature allows list allows to configure Grafana in a way so that the instance doesn’t call or only calls specific hosts. The vulnerability present starting with version 7.4.0-beta1 and prior to versions 7.5. CVE project by @Sn0wAlice (github_poc): https://github.com/yijikeji/CVE-2022-29170

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29170 and fix it if it is affected.

What it is: CVE-2022-29170 is a medium-severity server-side request forgery vulnerability in Grafana Grafana, published on 20 May 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29170 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana (Bitnami): affected from 7.4.0; fixed in 7.5.16, 8.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29170/ (Markdown: https://insights.sbomify.com/CVE-2022-29170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29170
- OSV: https://osv.dev/vulnerability/CVE-2022-29170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29170/
Summaries are generated and may contain mistakes; the official description above is the record.
