CVE-2022-29173 No protection against rollback attacks in go-tuf
Attackers can force clients to install older, vulnerable software by bypassing rollback protections in the go-tuf library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-29173?
CVE-2022-29173 is a high-severity vulnerability in theupdateframework go-tuf, published on 5 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
go-tuf is a Go implementation of The Update Framework (TUF). go-tuf does not correctly implement the client workflow for updating the metadata files for roles other than the root role. Specifically, checks for rollback attacks are not implemented correctly meaning an attacker can cause clients to install software that is older than the software which the client previously knew to be available, and may include software with known vulnerabilities. In more detail, the client code of go-tuf has several issues in regards to preventing rollback attacks: 1. It does not take into account the content of any previously trusted metadata, if available, before proceeding with updating roles other than the root role (i.e., steps 5.4.3.1 and 5.5.5 of the detailed client workflow). This means that any form of version verification done on the newly-downloaded metadata is made using the default value of zero, which always passes. 2. For both timestamp and snapshot roles, go-tuf saves these metadata files as trusted before verifying if the version of the metafiles they refer to is correct (i.e., steps 5.5.4 and 5.6.4 of the detailed client workflow). A fix is available in version 0.3.0 or newer. No workarounds are known for this issue apart from upgrading.
Weakness: CWE-354
Which versions are affected by CVE-2022-29173?
3 open source packages ship an affected version, including github.com/theupdateframework/go-tuf. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/theupdateframework/go-tuf Go | All versions | 0.3.0 |
github.com/theupdateframework/go-tuf Go | All versions | 0.3.0 |
github.com/theupdateframework/go-tuf Go | All versions | 0.3.0 |
Products include Theupdateframework Go-Tuf.
How do I fix CVE-2022-29173?
Upgrade github.com/theupdateframework/go-tuf to 0.3.0 or later.
Is CVE-2022-29173 being exploited?
There is no known exploitation of CVE-2022-29173 in the wild and no public exploit code.
Other vulnerabilities in theupdateframework go-tuf
Sources
Also known as GHSA-66x3-6cw3-v5gj, GO-2022-0444.