CVE-2022-29178 Incorrect Default Permissions in Cilium
Local users with group ID 1000 can access the Cilium API via Unix socket, potentially compromising integrity and availability on the host.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29178?
CVE-2022-29178 is a high-severity vulnerability in cilium, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Cilium prior to versions 1.9.16, 1.10.11, and 1.11.15 contains an incorrect default permissions vulnerability. Operating Systems with users belonging to the group ID 1000 can access the API of Cilium via Unix domain socket available on the host where Cilium is running. This could allow malicious users to compromise integrity as well as system availability on that host. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. A potential workaround is to modify Cilium's DaemonSet to run with a certain command, which can be found in the GitHub Security Advisory for this vulnerability.
Weakness: CWE-276
Which versions are affected by CVE-2022-29178?
14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | All versions | 1.9.16, 1.10.11, 1.11.5 |
github.com/cilium/cilium Go | All versions | 1.9.16 |
github.com/cilium/cilium Go | All versions | 1.9.16 |
github.com/cilium/cilium Go | From 1.10.0 | 1.10.11 |
github.com/cilium/cilium Go | From 1.10.0 | 1.10.11 |
github.com/cilium/cilium Go | From 1.11.0 | 1.11.5 |
8 more packages
github.com/cilium/cilium Go | From 1.11.0 | 1.11.5 |
cilium Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
cilium-operator Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
cilium-proxy Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
hubble Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
hubble-relay Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
hubble-ui Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
hubble-ui-backend Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
Products include Cilium Cilium.
How do I fix CVE-2022-29178?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.9.16, 1.10.11 or 1.11.5.
Is CVE-2022-29178 being exploited?
There is no known exploitation of CVE-2022-29178 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
- CVE-2023-39347 Cilium NetworkPolicy bypass via pod labels
Sources
Also known as BIT-cilium-2022-29178, BIT-cilium-operator-2022-29178, BIT-cilium-proxy-2022-29178, BIT-hubble-2022-29178, BIT-hubble-relay-2022-29178, BIT-hubble-ui-2022-29178 and 3 more.